Cisco

De OpenWikiBSD
Aller à : navigation, rechercher

Commandes courantes

SNMP

On va configurer le switch pour avoir :

  • Une lecture possible avec le mot de passe passread
  • Une écriture possible avec le mot de passe passwrite

En fait la communauté est une sorte de mot de passe

en
conf t
no snmp-server community public
snmp-server community passread RO
snmp-server community passwrite RW

Agrégation de ports

  • On crée un groupe de ports agrégés :
en
conf t

Switch(config)#           interface range fastEthernet 0/23 - 24
Switch(config-if-range)#  switchport mode access                
Switch(config-if-range)#  switchport access vlan 1              
Switch(config-if-range)#  channel-protocol lacp                 
Switch(config-if-range)#  channel-group 1 mode active           
Switch(config-if-range)#   exit

exit
wr mem
  • Maintenant, faites de même sur le serveur FreeBSD en face :


Debug

  • LACP n'est pas dispo sur les 3500XL, il faut passer aux 2950 minimum.
  • On détruit les éventuelles traces précédentes de port-channel:
en
conf t

Switch(config)#  no interface port-channel 1 
  • Ne pas oublier de mettre le port-channel dans le vlan 1, sinon, plus de communication, hors routage!

Remise à zéro de la configuration (test sur un Catalyst 3500XL)

Le lien chez cisco US


  • Utiliser Minicom (9600-8N1)
  • Démarrer le switch en gardant le bouton mode appuyé jusqu'à ce que la LED 1X s'éteigne.
  • flash_init
  • load_helper
  • delete flash:config.old
  • y
  • rename flash:config.text flash:config.old
  • boot
  • en
  • conf t


Upgrade Image IOS (testé sur un catalyst 3500XL)

Attention, tout ceci n'a été ni revalidé ni retesté par quelqu'un d'autre. en d'autres termes: Soyez prudents

  • Installez un serveur tftp sur un pingouin quelconque ( Utilisez atftpd et non pas tftpd )!
apt-get install atftpd
sed -i 's/USE_INETD=true/USE_INETD=false/' /etc/default/atftpd
atftpd --daemon

Les fichiers vont arriver dans /var/lib/tftpboot

  • bootez
  • en
  • conf t
  • inter vlan 1
  • ip address 10.0.0.10 255.255.255.0
  • no shut
  • exit
  • ip default-gateway 10.0.0.1
  • hostname Monswitcheamoi
  • ^Z
  • ' wr mem
  • On teste la connectivité IP :

ping 10.0.0.17

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 10.0.0.17, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/201/1001 ms

  • en
  • copy flash tftp (copie de sauvegarde)
  • copy tftp flash (on copie dans la flash la nouvelle image IOS)

( si ça ne marche pas, vérifiez les permissions :

  • chmod -R 777 /tftpboot
  • chown -R nobody /tftpboot)
  • si La flash est pleine, faites de la place : delete flash:Lenomdelimage
  • delete flash:/rep/*
  • rmdir flash:/rep

! il peut ne pas y avoir du tout assez de place !

C3548-2#dir flash: Directory of flash:/

2 -rwx 1645807 Mar 01 1993 03:29:13 c3500XL-c3h2s-mz-120.5.2-XU.bin 111 -rwx 272 Jan 01 1970 00:00:20 env_vars 112 -rwx 1844 Mar 01 1993 00:13:20 config.text

3612672 bytes total (1963008 bytes free)


Attention!! le C3548-2 n'a plus de flash:/html, donc plus de ip http server utilisable, a remettre depuis un autre! lien pour le faire

un autre

ici ce sont des : 3500 XL et non des 3550(16Mo de flash !) Enterprise Edition Command (ENC) Switch Software:

For a 3500XL there is only one memory configuration: 8 MB DRAM switches with 4 MB of Flash. depuis :[1]


 00:51:30: %SYS-5-RELOAD: Reload requested

C3500XL Boot Loader (C3500-HBOOT-M) Version 12.0(5.2)XU, MAINTENANCE INTERIM SOFTWARE

Compiled Mon 17-Jul-00 18:42 by ayounes

starting...

Base ethernet MAC Address: 00:04:27:ee:2f:40

Xmodem file system is available.

Initializing Flash...

flashfs[0]: 110 files, 3 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 3612672

flashfs[0]: Bytes used: 2770432

flashfs[0]: Bytes available: 842240

flashfs[0]: flashfs fsck took 3 seconds.

...done Initializing Flash.

Boot Sector Filesystem (bs:) installed, fsid: 3

Parameter Block Filesystem (pb:) installed, fsid: 4

Loading "flash:c3500XL-c3h2s-mz-120.5.2-XU.bin"...



File "flash:c3500XL-c3h2s-mz-120.5.2-XU.bin" uncompressed and installed, entry point: 0x3000

executing...



Restricted Rights Legend



Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.



cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706



Cisco Internetwork Operating System Software

IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.2)XU, MAINTENANCE INTERIM SOFTWARE

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Mon 17-Jul-00 18:29 by ayounes

Image text-base: 0x00003000, data-base: 0x00301F3C




Initializing C3500XL flash...

flashfs[1]: 110 files, 3 directories

flashfs[1]: 0 orphaned files, 0 orphaned directories

flashfs[1]: Total bytes: 3612672

flashfs[1]: Bytes used: 2770432

flashfs[1]: Bytes available: 842240

flashfs[1]: flashfs fsck took 4 seconds.

flashfs[1]: Initialization complete.

...done Initializing C3500XL flash.

C3500XL POST: System Board Test: Passed

C3500XL POST: Daughter Card Test: Passed

C3500XL POST: CPU Buffer Test: Passed

C3500XL POST: CPU Notify RAM Test: Passed

C3500XL POST: CPU Interface Test: Passed

C3500XL POST: Testing Switch Core: Passed

C3500XL POST: Testing Buffer Table: Passed

C3500XL POST: Data Buffer Test: Passed

C3500XL POST: Configuring Switch Parameters: Passed

C3500XL POST: Ethernet Controller Test: Passed

C3500XL POST: MII Test: Passed

cisco WS-C3548-XL (PowerPC403?) processor (revision 0x01) with 16384K/1024K bytes of memory.

Processor board ID FAA0445G012, with hardware revision 0x00

Last reset from warm-reset



Processor is running Enterprise Edition Software

Cluster command switch capable

Cluster member switch capable

48 FastEthernet?/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)




32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:04:27:EE:2F (interwiki):40

Motherboard assembly number: 73-3903-07

Power supply part number: 34-0971-01

Motherboard serial number: FAA04453837

Power supply serial number: PAC042905ZF

Model revision number: A0


Motherboard revision number: B0

Model number: WS-C3548-XL-EN

Activer le portfast

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800b1500.shtml


Activer le Relais dhcp

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a00804412bf.html

Quelle est mon adresse IP ?

en
show ip interface

Jouer avec SNMP et linux pour trouver une machine

tiré d'ici

  1. On découvre la liste des VLANS

snmpwalk @IP -c Communauté@N°VLAN -v 1 .1.3.6.1.4.1.9.9.46.1.3.1.1.2

SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1002 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1003 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1004 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1005 = INTEGER: 1

  1. Pour chaque VLAN

snmpwalk @IP -c Communauté@N°VLAN -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep B6

SNMPv2-SMI::mib-2.17.4.3.1.1.0.17.67.66.182.195 = Hex-STRING: 00 11 43 42 B6 C3

  1. Pour chaque VLAN, trouvez le Bridge number

.1.3.6.1.2.1.17.4.3.1.2

Si Integer =0 : ya rien

SNMPv2-SMI::mib-2.17.4.3.1.2.0.17.67.66.182.195 = INTEGER: 50 SNMPv2-SMI::mib-2.17.4.3.1.2.1.0.12.0.0.0 = INTEGER: 0


  1. Get the bridge port to ifIndex (1.3.6.1.2.1.2.2.1.1) mapping, dot1dBasePortIfIndex (.1.3.6.1.2.1.17.1.4.1.2):
  1. Retrouver le IfName

snmpwalk ip -c comm@1 -v 1 .1.3.6.1.2.1.31.1.1.1.1

IF-MIB::ifName.1 = STRING: VL1 IF-MIB::ifName.2 = STRING: Fa0/1 IF-MIB::ifName.3 = STRING: Fa0/2 IF-MIB::ifName.4 = STRING: Fa0/3


voir ça sur le CPAN

Au final , pour trouver port du switche de @MAC donnée :

exemple : Où est branchée la machine d'@MAC : 00:04:76:A3:8A:BE

snmpwalk Catalyst -c community -v 1 .1.3.6.1.4.1.9.9.46.1.3.1.1.2 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1002 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1003 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1004 = INTEGER: 1 SNMPv2-SMI::enterprises.9.9.46.1.3.1.1.2.1.1005 = INTEGER: 1

->Donne la liste des VLAN

snmpwalk Catalyst -c community@1 -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep "00 04 76 A3 8A BE" SNMPv2-SMI::mib-2.17.4.3.1.1.0.4.118.163.138.190 = Hex-STRING: 00 04 76 A3 8A BE

snmpwalk Catalyst -c community@1002 -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep "00 04 76 A3 8A BE" snmpwalk Catalyst -c community@1003 -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep "00 04 76 A3 8A BE" snmpwalk Catalyst -c community@1004 -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep "00 04 76 A3 8A BE" snmpwalk Catalyst -c community@1005 -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep "00 04 76 A3 8A BE"

-> Trouve la MAC parmi les VLAN MAC->0.4.118.163.138.190 en décimal

snmpwalk Catalyst -c community@1 -v 1 .1.3.6.1.2.1.17.4.3.1.2.0.4.118.163.138.190 SNMPv2-SMI::mib-2.17.4.3.1.2.0.4.118.163.138.190 = INTEGER: 13

-> Trouve le Numéro de bridge

snmpwalk Catalyst -c community@1 -v 1 .1.3.6.1.2.1.17.1.4.1.2.13 SNMPv2-SMI::mib-2.17.1.4.1.2.13 = INTEGER: 2

-> Donne l'ifIndex

snmpwalk Catalyst -c community@1 -v 1 .1.3.6.1.2.1.31.1.1.1.1.2 IF-MIB::ifName.2 = STRING: Fa0/1

-> La machine d'@MAC donnée est branchée sur leport Fa0/1 du switch.

    • //A tester sur un pile de switchess..//**


Script shell qui fait tout ça tout seul

#!/bin/bash


# On ne recherche que sur le VLAN 1

COM="LaCave"
SW="Catalyst"
echo "Donner adresse MAC à moi, steuplé"
read MACDQ
MACHX=`echo $MACDQ | sed "s/:/ /g" `

MACDC=`snmpwalk $SW -c $COM@1 -v 1 .1.3.6.1.2.1.17.4.3.1.1 |grep "$MACHX" |sed "s/SNMPv2-SMI::mib-2.17.4.3.1.1.//" | sed "s/ = Hex-STRING: $MACHX//"`

BRDGNUM=`snmpwalk $SW -c $COM@1 -v 1  .1.3.6.1.2.1.17.4.3.1.2.$MACDC |sed "s/.* = INTEGER: //"`

IFINDEX=`snmpwalk $SW -c $COM@1 -v 1  .1.3.6.1.2.1.17.1.4.1.2.$BRDGNUM |sed "s/.* = INTEGER: //"`

INTF=`snmpwalk $SW -c $COM@1 -v 1  .1.3.6.1.2.1.31.1.1.1.1.$IFINDEX |sed "s/.* = STRING: //"`

echo $INTF


Remise à zéro d'un routeur ADSL 837

  • Connecter le port série du routeur (9600/8/N/1)
  • Le démarrer:
Boot : 

System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2002 by cisco Systems, Inc.
C800/SOHO series (Board ID: 23-127) platform with 49152 Kbytes of main memory

  • Ici faire un CTRL+Pause sur l'ordinateur.
monitor: command "boot" aborted due to user interrupt

rommon 1 > confreg 0x2142 On change de registre rommon 2 > reset

......(long)....


Enter initial configuration dialog (yes/no)

yes


reset a cisco router to factory default settings :---------------

no.

enable

(config)# banner motd ! Enter TEXT Message. End witxh character '!'. Coller ici son texte formaté dans un éditeur de texte Après une nouvelle ligne taper ! C'est tout

  • On enregistre le tout :

end enable wr mem

  • Maintenant on repasse en mode confreg 0x2102, sinon les changements seront perdus au reboot:

confreg 0x2102

Attention, je n'ai plus de routeur pour valider le mode dans lequel il faut taper ceci (mode enable, mode config..)



mode config : ip http secure-ser ip http secure-server

Passer en mode config interface : (config)#interface ethernet 0 (config-if )# ip address 10.0.0.50 255.255.255.0

(config)#ip default-gateway 10.0.0.1



navigateur : JVM de MS!!!!!!


line vty 0 4 privilege level 15 login local password T1V1rt

transport input ssh


!!Si on définit un mdp enable et un mdp secret, lorsque l'on tape la commande enable, il faut donner le pass secret!!!


(config)#username USER privilege 15 password PASS end wr mem

no ip bootp server no cdp run no ip source-route

(config)#interface ethernet 0 Ganesh(config-if)#no????? ip redirects config-if)#no ip red Ganesh(config-if)#no ip redirects Ca c'est sur (config)#interface atM 0 Ganesh(config-if)#no ip proxy-arp


patatras......tout cela est perdu (console/SSH/http.s) si le mode est 0x2142 (sh ver)...il FAUT le rebasculer en 0x2102 ( en mode config)et /ou copier la config (cop run star)....


reboot HARD 30' :CTRL+Arret Defil rommon 1 > confreg 0x2102 You must reset or power cycle for new config to take effect rommon 2 > resetú System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1) TAC Support: http://www.cisco.com/tac Copyright (c) 2002 by cisco Systems, Inc. C800/SOHO series (Board ID: 23-127) platform with 49152 Kbytes of main memory

et ben,non. CT pas perdu juste pas relu au reboot toutsemble marcher non, ssh et http perdus

ip http secure-server ip http authentication enable exit Ganesh#wr me

Building configuration... [OK] Ganesh#

http://ip auth avec les credetials de enable

clic https C parti fo la jvm MS

reste en SDM


show processes

no shutdown (sur conf-if)

pass enable = pass interface web !!!!!

Augmenter les perfs

undebug all (A tester selon la version d'IOS)

CMS Cluster Management System

  • Nom de switche : max 31 caractères. Les 2 derniers caractères NE PEUVENT PAS être de la forme **-n** où n est un nombre !!!!
  • pb de config != sur deux switches linkés : sur FE : pb de perf. sur Gb : pas de message, et le lien est down!!!


VTP: VLan Trunking Protocol

permet de faire la conf de vlan sur une machine et de laisser vtp propager les infos au groupe vtp.

[Doc Labo-Cisco]

mode server sur un et mode client sur les autres rien en mode transparent (po compris)

Accélérer l'activation des ports d'un switch Cisco =

[2]

minicom
Mon2950>
Mon2950>en
Password: 
Mon2950#
Mon2950#conf t
 Enter configuration commands, one per line.  End with CNTL/Z.
Mon2950(config)#in rang fas 0/1 - 24
Mon2950(config)#interface range fastEthernet 0/1 - 24
Mon2950(config-if-range)#switchport mode access
Mon2950(config-if-range)#spanning-tree portfast
  %Warning: portfast should only be enabled on ports connected to a single
  host. Connecting hubs, concentrators, switches, bridges, etc... to this
  interface  when portfast is enabled, can cause temporary bridging loops.
  Use with CAUTION
  %Portfast will be configured in 24 interfaces due to the range command 
  but will only have effect when the interfaces are in a non-trunking mode.
Mon2950(config-if-range)#exit
Mon2950(config)#exit
Mon2950#
Mon2950#copy running-config startup-config

Destination filename [startup-config]? Building configuration... [OK] Mon2950#

Notes IOS

Reset d'un Switch (testé sur un 2950)

  • Débrancher le switch
  • Appuyer sur le bouton mode et garder appuyé
  • Brancher le switch
  • Attendre environ 5 secondes. La diode SYST doit clignoter orange/vert
  • Lancer un minicom bien configuré ( /dev/ttyUSB0 et 9600 bps)
flash_init
load_helper
rename flash:config.text flash:config.old
boot

Puis suivre la reconfig

Divers

    • //! //** au début d'une ligne la commente

Mode Enable

sh interfaces status



Cat2950# write erase Erasing the nvram filesystem will remove all files! Continue? [confirm]y[OK] Erase of nvram: complete Cat2950# Cat2950# reload

System configuration has been modified. Save? [yes/no]: n

!--- Do not save the configuration at this prompt. Otherwise, the switch !--- reloads with the current running configuration and does not reset to default.

Proceed with reload? [confirm]y

Mode COnf term

interface vlan 1

Mode Config-if

ip adrress IP mask end => config wr mem


cluster commander-address MAC1 member 1 name ClusterSR4 vlan 1

cluster commander-address MAC1 member 2 name ClusterSR4 vlan 1


ConfiGs


Config vlan IOS----

en vlan database : deprecated (fait comme ca qd mem) SR5-2950-48(vlan)#vlan 93 name ?

 WORD  The ascii name for the VLAN

SR5-2950-48(vlan)#vlan 93 name administratif VLAN 93 added:

   Name: administratif

SR5-2950-48(vlan)#exit APPLY completed. Exiting....

conf t inter fa0/1 (config-if)

switchport mode access switchport access NOMVLAN 93 exit




Un trunk est est "uplink" spécifique entre 2 switchs. Pour que les switchs communiquent entre eux, il faut qu'ils soient inter-reliés par des liens trunk.

Alors il faut utiliser les commandes suivantes sur chaque switch : (config)# interface f0/1 le lien trunk va être sur le port 1 du switch (config-if)# switchport mode trunk indique que le port 1 servira de lien vers un autre switch et non de port pour un PC

http://cisco.goffinet.org/


Configurer plusieurs interfaces en même temps sur un 2950 Document Actions

   * Send this page to somebody

Description de la fonctionnalité Interface-range macros. Description de la fonctionnalité Interface-Range Macros des 2950

On aura vite remarqué que les switches tournant sous un Cisco IOS disposent de la même interface de configuration et de la même syntaxe de base que les routeurs.

Toutefois, les switches disposent quelques fois de plusieurs dizaines d'interfaces. Il peut s'avérer fastidieux de les configurer une à une avec des paramètres identiques. L'utilisation de la fonctionnalité Interface-Range Macros sur des 2950 peut faciliter le travail !

Tout simplement on définira un nom de macro qui reprendra un ensemble d'interfaces. On utilisera ce nom comme le nom d'une interface physique précédé des paramètres range macro.

(config)#define interface-range macro-name interface-range

- macro-name est un mot quelconque de 32 caractères maximum - interface-range comportera la plage d'interfaces respectant la syntaxe :

   * vlan vlan-id
   * fastethernet slot/{premier_port} - {dernier_port} [1]

Concrètement imaginons que nous devions configurer les ports 2 à 12 d'un 2950-12 de manière identique en prenant le nom de macro macro1 :

(config)#define interface-range macro1 fastethernet 0/2 - 12 (config)#interface range macro macro1 (config-if-range)#commandes ...



http://www.labo-cisco.com/ArticleComp.asp?ARID=65


http://forum.labo-cisco.com/viewtopic.php?t=3623 interface range fastethernet 0/1 - 24